re = /auth-worker.*?sql\((?P<user>\w+),(?P<ip>\d+(?:\.\d+){3}).*?(?:password mismatch|unknown user)\s*\(given password:\s*(?P=user)\)/i
str = 'Jun 1 04:16:24 mail dovecot: auth-worker(3158): sql(ryan,193.42.32.170): unknown user (given password: ryan)
Jun 1 04:16:24 mail dovecot: auth-worker(3158): sql(chris,193.42.32.170): unknown user (given password: ryan)
Jun 1 04:16:24 mail dovecot: auth-worker(3158): sql(chris,193.42.32.170): unknown user (given password: chris)
Jun 1 04:16:24 mail dovecot: auth-worker(3158): sql(user,193.42.32.170): Password mismatch (given password: user)
Jun 1 04:16:24 mail dovecot: auth-worker(3158): sql(admin,193.42.32.170): unknown user (given password: admin123)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end