const regex = new RegExp('auth-worker.*?sql\\((?P<user>\\w+),(?P<ip>\\d+(?:\\.\\d+){3}).*?(?:password mismatch|unknown user)\\s*\\(given password:\\s*(?P=user)\\)', 'ig')
const str = `Jun 1 04:16:24 mail dovecot: auth-worker(3158): sql(ryan,193.42.32.170): unknown user (given password: ryan)
Jun 1 04:16:24 mail dovecot: auth-worker(3158): sql(chris,193.42.32.170): unknown user (given password: ryan)
Jun 1 04:16:24 mail dovecot: auth-worker(3158): sql(chris,193.42.32.170): unknown user (given password: chris)
Jun 1 04:16:24 mail dovecot: auth-worker(3158): sql(user,193.42.32.170): Password mismatch (given password: user)
Jun 1 04:16:24 mail dovecot: auth-worker(3158): sql(admin,193.42.32.170): unknown user (given password: admin123)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}