// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)auth-worker.*?sql\((?P<user>\w+),(?P<ip>\d+(?:\.\d+){3}).*?(?:password mismatch|unknown user)\s*\(given password:\s*(?P=user)\)").unwrap();
let string = "Jun 1 04:16:24 mail dovecot: auth-worker(3158): sql(ryan,193.42.32.170): unknown user (given password: ryan)
Jun 1 04:16:24 mail dovecot: auth-worker(3158): sql(chris,193.42.32.170): unknown user (given password: ryan)
Jun 1 04:16:24 mail dovecot: auth-worker(3158): sql(chris,193.42.32.170): unknown user (given password: chris)
Jun 1 04:16:24 mail dovecot: auth-worker(3158): sql(user,193.42.32.170): Password mismatch (given password: user)
Jun 1 04:16:24 mail dovecot: auth-worker(3158): sql(admin,193.42.32.170): unknown user (given password: admin123)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}