using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"auth-worker.*?sql\((?P<user>\w+),(?P<ip>\d+(?:\.\d+){3}).*?(?:password mismatch|unknown user)\s*\(given password:\s*(?P=user)\)";
string input = @"Jun 1 04:16:24 mail dovecot: auth-worker(3158): sql(ryan,193.42.32.170): unknown user (given password: ryan)
Jun 1 04:16:24 mail dovecot: auth-worker(3158): sql(chris,193.42.32.170): unknown user (given password: ryan)
Jun 1 04:16:24 mail dovecot: auth-worker(3158): sql(chris,193.42.32.170): unknown user (given password: chris)
Jun 1 04:16:24 mail dovecot: auth-worker(3158): sql(user,193.42.32.170): Password mismatch (given password: user)
Jun 1 04:16:24 mail dovecot: auth-worker(3158): sql(admin,193.42.32.170): unknown user (given password: admin123)";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}