#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*def\s+([^(]*)(?:.*?:$)"
Local $sString = "import re " & @CRLF & _
"def extractName(s) -> str:" & @CRLF & _
" return "def kek(s)"" & @CRLF & _
"" & @CRLF & _
" return """" & @CRLF & _
" def oops(s):" & @CRLF & _
" """"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")