re = /^\s*def\s+([^(]*)(?:.*?:$)/m
str = 'import re
def extractName(s) -> str:
return "def kek(s)"
return """
def oops(s):
"""'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end