package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*def\s+([^(]*)(?:.*?:$)`)
var str = `import re
def extractName(s) -> str:
return "def kek(s)"
return """
def oops(s):
"""`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}