using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*def\s+([^(]*)(?:.*?:$)";
string input = @"import re
def extractName(s) -> str:
return ""def kek(s)""
return """"
def oops(s):
""""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}