$re = '/^\s*def\s+([^(]*)(?:.*?:$)/m';
$str = 'import re
def extractName(s) -> str:
return "def kek(s)"
return """
def oops(s):
"""';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);