# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^:]+:(.+$)/$1/gm;t' <<< "Имя: Елена
Телефон: +79213763000
Почта: ela-bogva@mail.ru"