$re = '/[^:]+:(.+$)/m';
$str = 'Имя: Елена
Телефон: +79213763000
Почта: ela-bogva@mail.ru';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;