re = /#\b.*?\b#|\B#\w+/
str = 'Case 1 :
Hello, #how are you# today.
In this case, I want to detect how are you. Now if there is only a word, then the above case is to be ignored.
Case 2 :
Hello, #how are you #today. '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end