import Foundation
let pattern = ##"#\b.*?\b#|\B#\w+"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
Case 1 :
Hello, #how are you# today.
In this case, I want to detect how are you. Now if there is only a word, then the above case is to be ignored.
Case 2 :
Hello, #how are you #today.
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)