#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:[^\r\n,{}]+)(?:,(?=[^}]*{)|\s*{[\s]*})"
Local $sString = "#colorful {" & @CRLF & _
" color: #0000;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
".my > .empty + .selector {" & @CRLF & _
"" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"[this] {}" & @CRLF & _
"" & @CRLF & _
"* > div {" & @CRLF & _
" background-image: url(http://...);" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"* .one {" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")