using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[^\r\n,{}]+)(?:,(?=[^}]*{)|\s*{[\s]*})";
string input = @"#colorful {
color: #0000;
}
.my > .empty + .selector {
}
[this] {}
* > div {
background-image: url(http://...);
}
* .one {
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}