re = /(?:[^\r\n,{}]+)(?:,(?=[^}]*{)|\s*{[\s]*})/
str = '#colorful {
color: #0000;
}
.my > .empty + .selector {
}
[this] {}
* > div {
background-image: url(http://...);
}
* .one {
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end