$re = '/(?:[^\r\n,{}]+)(?:,(?=[^}]*{)|\s*{[\s]*})/';
$str = '#colorful {
color: #0000;
}
.my > .empty + .selector {
}
[this] {}
* > div {
background-image: url(http://...);
}
* .one {
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);