const regex = /(?:[^\r\n,{}]+)(?:,(?=[^}]*{)|\s*{[\s]*})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[^\\r\\n,{}]+)(?:,(?=[^}]*{)|\\s*{[\\s]*})', 'g')
const str = `#colorful {
color: #0000;
}
.my > .empty + .selector {
}
[this] {}
* > div {
background-image: url(http://...);
}
* .one {
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}