using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=\{)|(?<=\})";
string substitution = @"\n";
string input = @"How {$can} {$we} split this {$string}?";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}