use strict;
my $str = 'How {$can} {$we} split this {$string}?';
my $regex = qr/(?=\{)|(?<=\})/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";