$re = '/(?=\{)|(?<=\})/';
$str = 'How {$can} {$we} split this {$string}?';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;