re = /(?=\{)|(?<=\})/
str = 'How {$can} {$we} split this {$string}?'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result