import Foundation
let pattern = #"(?=\{)|(?<=\})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"How {$can} {$we} split this {$string}?"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)