using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(Playing|Listening).*?\(\{2\}\)\0(([^\\0].).)$";
string substitution = @"\U$1";
string input = @"\0Music\01\0Playing {0} - {1} [{3}] ({2})\0With You Tonight\0viewtifulday\0osu!\0Normal\0";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}