$re = '/(Playing|Listening).*?\(\{2\}\)\0(([^\\\\0].).)$/';
$str = '\\0Music\\01\\0Playing {0} - {1} [{3}] ({2})\\0With You Tonight\\0viewtifulday\\0osu!\\0Normal\\0';
$subst = "\U$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;