// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(Playing|Listening).*?\(\{2\}\)\0(([^\\0].).)$").unwrap();
let string = "\\0Music\\01\\0Playing {0} - {1} [{3}] ({2})\\0With You Tonight\\0viewtifulday\\0osu!\\0Normal\\0";
let substitution = "\\U$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}