import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Playing|Listening).*?\\(\\{2\\}\\)\\0(([^\\\\0].).)$";
final String string = "\\0Music\\01\\0Playing {0} - {1} [{3}] ({2})\\0With You Tonight\\0viewtifulday\\0osu!\\0Normal\\0";
final String subst = "\\U$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}