const regex = /(Playing|Listening).*?\(\{2\}\)\0(([^\\0].).)$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(Playing|Listening).*?\\(\\{2\\}\\)\\0(([^\\\\0].).)$', 'g')
const str = `\\0Music\\01\\0Playing {0} - {1} [{3}] ({2})\\0With You Tonight\\0viewtifulday\\0osu!\\0Normal\\0`;
const subst = `\U$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);