#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<unit_type>SFS)(?P<unit_size>300|250|200)(?P<mounting_type>A|B)(?P<decompression_feature>0)(?P<sep_1>-)(?P<cracking_pressure>1)(?P<sep_2>-)(?P<unit_series>4X)(?P<sep_3>/)(?P<seal_material>|)(?P<additional_details>(.|[0-9])*)$"
Local $sString = "SFS300A0-1-4X/" & @CRLF & _
"SFS250A0-1-4X/" & @CRLF & _
"SFS200A0-1-4X/" & @CRLF & _
"SFS200B0-1-4X/" & @CRLF & _
"SFS250A0-1-4X/Q2TQ.G24" & @CRLF & _
"SFS250A0-1-4X/Q2TQ2G24" & @CRLF & _
"SFS200A0-1-4X/Q2TQ2G24" & @CRLF & _
"SFS300A0-1-4X/Q2TQ2G24" & @CRLF & _
"SFS250B0-1-4X/" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")