import re
regex = re.compile(r"^(?P<unit_type>SFS)(?P<unit_size>300|250|200)(?P<mounting_type>A|B)(?P<decompression_feature>0)(?P<sep_1>-)(?P<cracking_pressure>1)(?P<sep_2>-)(?P<unit_series>4X)(?P<sep_3>/)(?P<seal_material>|)(?P<additional_details>(.|[0-9])*)$", flags=re.MULTILINE)
test_str = ("SFS300A0-1-4X/\n"
"SFS250A0-1-4X/\n"
"SFS200A0-1-4X/\n"
"SFS200B0-1-4X/\n"
"SFS250A0-1-4X/Q2TQ.G24\n"
"SFS250A0-1-4X/Q2TQ2G24\n"
"SFS200A0-1-4X/Q2TQ2G24\n"
"SFS300A0-1-4X/Q2TQ2G24\n"
"SFS250B0-1-4X/\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")