import Foundation
let pattern = #"^(?P<unit_type>SFS)(?P<unit_size>300|250|200)(?P<mounting_type>A|B)(?P<decompression_feature>0)(?P<sep_1>-)(?P<cracking_pressure>1)(?P<sep_2>-)(?P<unit_series>4X)(?P<sep_3>/)(?P<seal_material>|)(?P<additional_details>(.|[0-9])*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
SFS300A0-1-4X/
SFS250A0-1-4X/
SFS200A0-1-4X/
SFS200B0-1-4X/
SFS250A0-1-4X/Q2TQ.G24
SFS250A0-1-4X/Q2TQ2G24
SFS200A0-1-4X/Q2TQ2G24
SFS300A0-1-4X/Q2TQ2G24
SFS250B0-1-4X/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)