import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<unit_type>SFS)(?P<unit_size>300|250|200)(?P<mounting_type>A|B)(?P<decompression_feature>0)(?P<sep_1>-)(?P<cracking_pressure>1)(?P<sep_2>-)(?P<unit_series>4X)(?P<sep_3>/)(?P<seal_material>|)(?P<additional_details>(.|[0-9])*)$";
final String string = "SFS300A0-1-4X/\n"
+ "SFS250A0-1-4X/\n"
+ "SFS200A0-1-4X/\n"
+ "SFS200B0-1-4X/\n"
+ "SFS250A0-1-4X/Q2TQ.G24\n"
+ "SFS250A0-1-4X/Q2TQ2G24\n"
+ "SFS200A0-1-4X/Q2TQ2G24\n"
+ "SFS300A0-1-4X/Q2TQ2G24\n"
+ "SFS250B0-1-4X/\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}