$re = '/^(?P<unit_type>SFS)(?P<unit_size>300|250|200)(?P<mounting_type>A|B)(?P<decompression_feature>0)(?P<sep_1>-)(?P<cracking_pressure>1)(?P<sep_2>-)(?P<unit_series>4X)(?P<sep_3>/)(?P<seal_material>|)(?P<additional_details>(.|[0-9])*)$/m';
$str = 'SFS300A0-1-4X/
SFS250A0-1-4X/
SFS200A0-1-4X/
SFS200B0-1-4X/
SFS250A0-1-4X/Q2TQ.G24
SFS250A0-1-4X/Q2TQ2G24
SFS200A0-1-4X/Q2TQ2G24
SFS300A0-1-4X/Q2TQ2G24
SFS250B0-1-4X/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);