#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([a-zA-Z])*([0-9 -])+([a-zA-Z \.])+$"
Local $sString = "1234" & @CRLF & _
"4775" & @CRLF & _
"773" & @CRLF & _
"" & @CRLF & _
"6 S Surfway" & @CRLF & _
"70 N Grove St" & @CRLF & _
"1661-114 Old Country Rd" & @CRLF & _
"" & @CRLF & _
"Calverton " & @CRLF & _
"Freeport " & @CRLF & _
"Riverhead " & @CRLF & _
"" & @CRLF & _
"85-10 151st Ave" & @CRLF & _
"70 N Grove St" & @CRLF & _
"703 Fresh Pond Av" & @CRLF & _
"B5 Schooner Ln" & @CRLF & _
"91 W. Parkview Dr" & @CRLF & _
"2105 Wallace Ave" & @CRLF & _
"1661-43 Old Country Rd" & @CRLF & _
"85-10 151 Ave"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")