use strict;
my $str = '1234
4775
773
6 S Surfway
70 N Grove St
1661-114 Old Country Rd
Calverton
Freeport
Riverhead
85-10 151st Ave
70 N Grove St
703 Fresh Pond Av
B5 Schooner Ln
91 W. Parkview Dr
2105 Wallace Ave
1661-43 Old Country Rd
85-10 151 Ave';
my $regex = qr/^([a-zA-Z])*([0-9 -])+([a-zA-Z \.])+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}