package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-zA-Z])*([0-9 -])+([a-zA-Z \.])+$`)
var str = `1234
4775
773
6 S Surfway
70 N Grove St
1661-114 Old Country Rd
Calverton
Freeport
Riverhead
85-10 151st Ave
70 N Grove St
703 Fresh Pond Av
B5 Schooner Ln
91 W. Parkview Dr
2105 Wallace Ave
1661-43 Old Country Rd
85-10 151 Ave`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}