const regex = /^([a-zA-Z])*([0-9 -])+([a-zA-Z \.])+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-zA-Z])*([0-9 -])+([a-zA-Z \\.])+$', 'gm')
const str = `1234
4775
773
6 S Surfway
70 N Grove St
1661-114 Old Country Rd
Calverton
Freeport
Riverhead
85-10 151st Ave
70 N Grove St
703 Fresh Pond Av
B5 Schooner Ln
91 W. Parkview Dr
2105 Wallace Ave
1661-43 Old Country Rd
85-10 151 Ave`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}