$re = '/^([a-zA-Z])*([0-9 -])+([a-zA-Z \.])+$/m';
$str = '1234
4775
773
6 S Surfway
70 N Grove St
1661-114 Old Country Rd
Calverton
Freeport
Riverhead
85-10 151st Ave
70 N Grove St
703 Fresh Pond Av
B5 Schooner Ln
91 W. Parkview Dr
2105 Wallace Ave
1661-43 Old Country Rd
85-10 151 Ave';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);