#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:(?:<[^>]+>)*[^<.\n]*)*\.){2}"
Local $sString = "<p><img src="example.image.com" alt="foo">Text. More text.</p>" & @CRLF & _
"<p>Text.<img src="example.image.com" alt="foo">Text. More text.</p>" & @CRLF & _
"...." & @CRLF & _
"text." & @CRLF & _
".text." & @CRLF & _
"<...............>.text.<br>text" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")