const regex = /^(?:(?:(?:<[^>]+>)*[^<.\n]*)*\.){2}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:(?:<[^>]+>)*[^<.\\n]*)*\\.){2}', 'gm')
const str = `<p><img src="example.image.com" alt="foo">Text. More text.</p>
<p>Text.<img src="example.image.com" alt="foo">Text. More text.</p>
....
text.
.text.
<...............>.text.<br>text
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}