$re = '/^(?:(?:(?:<[^>]+>)*[^<.\n]*)*\.){2}/m';
$str = '<p><img src="example.image.com" alt="foo">Text. More text.</p>
<p>Text.<img src="example.image.com" alt="foo">Text. More text.</p>
....
text.
.text.
<...............>.text.<br>text
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);