re = /^(?:(?:(?:<[^>]+>)*[^<.\n]*)*\.){2}/m
str = '<p><img src="example.image.com" alt="foo">Text. More text.</p>
<p>Text.<img src="example.image.com" alt="foo">Text. More text.</p>
....
text.
.text.
<...............>.text.<br>text
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end