using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.{5})(\/?)";
string input = @"07070
07070/01010
0/0/0/BBBBB
AAAAA/BBBBB/CCCCC
AAAAA/BBBBB/C/CCC";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}