import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.{5})(\\/?)";
final String string = "07070\n"
+ "07070/01010\n"
+ "0/0/0/BBBBB\n"
+ "AAAAA/BBBBB/CCCCC\n"
+ "AAAAA/BBBBB/C/CCC";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}