$re = '/(.{5})(\/?)/m';
$str = '07070
07070/01010
0/0/0/BBBBB
AAAAA/BBBBB/CCCCC
AAAAA/BBBBB/C/CCC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);