#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:is|are) ([a-zA-Z0-9- ]+?) if\b"
Local $sString = "A relation is well-defined if each element in the domain is assigned to a unique element in the range." & @CRLF & _
"" & @CRLF & _
"invertible if and only" & @CRLF & _
"" & @CRLF & _
"A mapping is invertible on sth if and only if it is both one-to-one and onto" & @CRLF & _
"" & @CRLF & _
"infinite set, we give a specific proof for the smallest integer being considered, followed by a generic argument showing that" & @CRLF & _
"" & @CRLF & _
"mathematical induction. Instead of attempting to verify a statement about some subset S of the positive integers N on a case-by-case basis, an impossible task if S is an infinite set, we give a specific proof for the smallest integer being considered, followed by a generic argument showing that if the statement holds for a given case, then it must also hold for the next case in the sequence."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")