package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:is|are) ([a-zA-Z0-9- ]+?) if\b`)
var str = `A relation is well-defined if each element in the domain is assigned to a unique element in the range.
invertible if and only
A mapping is invertible on sth if and only if it is both one-to-one and onto
infinite set, we give a specific proof for the smallest integer being considered, followed by a generic argument showing that
mathematical induction. Instead of attempting to verify a statement about some subset S of the positive integers N on a case-by-case basis, an impossible task if S is an infinite set, we give a specific proof for the smallest integer being considered, followed by a generic argument showing that if the statement holds for a given case, then it must also hold for the next case in the sequence.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}