use strict;
my $str = 'A relation is well-defined if each element in the domain is assigned to a unique element in the range.
invertible if and only
A mapping is invertible on sth if and only if it is both one-to-one and onto
infinite set, we give a specific proof for the smallest integer being considered, followed by a generic argument showing that
mathematical induction. Instead of attempting to verify a statement about some subset S of the positive integers N on a case-by-case basis, an impossible task if S is an infinite set, we give a specific proof for the smallest integer being considered, followed by a generic argument showing that if the statement holds for a given case, then it must also hold for the next case in the sequence.';
my $regex = qr/(?:is|are) ([a-zA-Z0-9- ]+?) if\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}