// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:is|are) ([a-zA-Z0-9- ]+?) if\b").unwrap();
let string = "A relation is well-defined if each element in the domain is assigned to a unique element in the range.
invertible if and only
A mapping is invertible on sth if and only if it is both one-to-one and onto
infinite set, we give a specific proof for the smallest integer being considered, followed by a generic argument showing that
mathematical induction. Instead of attempting to verify a statement about some subset S of the positive integers N on a case-by-case basis, an impossible task if S is an infinite set, we give a specific proof for the smallest integer being considered, followed by a generic argument showing that if the statement holds for a given case, then it must also hold for the next case in the sequence.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}