using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:is|are) ([a-zA-Z0-9- ]+?) if\b";
string input = @"A relation is well-defined if each element in the domain is assigned to a unique element in the range.
invertible if and only
A mapping is invertible on sth if and only if it is both one-to-one and onto
infinite set, we give a specific proof for the smallest integer being considered, followed by a generic argument showing that
mathematical induction. Instead of attempting to verify a statement about some subset S of the positive integers N on a case-by-case basis, an impossible task if S is an infinite set, we give a specific proof for the smallest integer being considered, followed by a generic argument showing that if the statement holds for a given case, then it must also hold for the next case in the sequence.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}